MUNTE

a)1475210

b)75210 cifra maxima nu poate fi prima cifra. n<=9

c)147 cifra maxima nu poate fi ultima .   n=m

d)14237510 muntele nu poate avea mai multe  varfuri.  n>9

n                        m        ok

1475210     1475210      1

147

PSEUDOCOD:

-Start

Citeste n

M=n

Ok=1

-Cat timp n>9&&n%10<[n/10]%10 executa

N=[n/10]

-Daca n<=0|| n=m atunci ok=0

-Cat timp n>9&&n%10>[n/10]%10 executa

N=[n/10]

-Daca n>9 atunci ok=0

-Daca ok==1 atunci scrie “MUNTE”

Altfel “NU ESTE MUNTE”

-stop

Eliminarea unor cifre dintr’un numar

Se da un numar natural.Sa se elimine din numar cifrele prime.

[BAZA ZECE]

1742= 2*pow(10,0)* 4 *10*7*pow(10,2)+1*pow(10,3)

n                             c                   p               m

835476                                     1              0

6                     10           6

7

4                   100          46

5

3

8                    1000         846

m=m+c*p

p=p*10

Se da un numar natural.Sa se elimine din numar cifrele prime.

-start

citeste n

m=0

p=1

-cat timp n!=0 executa

c=n%10

n=[n/10]

daca c!=2&&c!=3&&c!=5&&c!=7 atunci

m=m+c*p

p=p*10

scrie m

-stop

MINIM –MAXIM

1.ENUNT:

Se da un numar natural n.Sa se  afiseze cea mai mare  cifra.

n                      c          max

148362          2         0

6         2

3         6

8

4         8

1

Pseudocod:

-start

Max=0

-cat timp n!=0 executa

C=n%10

N=n/10

-daca c> max atunci max=c

Scrie max

-stop

2.ENUNT:

Se da un numar natural n. Sa se  afiseze cea mai mica  cifra:

start

Citeste n

Min=9

-cat timp n!=0 executa

C=n%10

N=n/10

-daca c<min atunci min=c

Scrie min

-stop

CIFRELE UNUI NUMAR

A.ENUNT:

Se da un numar  natural n.Se cere sa se  afiseze cifrele numarului.

B.Exemplu:

n                 c

1472

147           2

14              7

1                 4

0                 1

N=1472

c=n%10=1472%10=2

n=n/10=1472/10=147

c=n%10=147%10=7

n=n/10=147/10=14

c=n%10=14%10=4

n=n/10=14/10=1

c=n%10=1%10=1

n=n/10=1/10=0

C.Algoritmul este:

-se citeste numarul

-cat timp n!=0 executa

-aflam ultima cifra(c=n%10)

-eliminam ultima  cifra( n=n/10)

-afiseaza c

D.Pseudocod

-start

Citeste n

-cat timp n!=0 executa

C=n%10

N=n/10

Scrie c

-stop

OBSERVATII:

-numarul nu se modifica

-cifrele numarului se  afla in ordine  inverse:prima cifra unitatilor,apoi cifra zecilor,apoi cifra sutelor etc.

CMMDC-prin scaderi repetate .ALGORITMUL LUI EUCLID

a      b               (90,42)=6

90  42                (90,0)=90

48   42              (0,80)=80

6     42                b=0   cmmdc=b

6     36                a=b     cmmdc=a

6     30               a*b=0 cmmdc=a+b

6    24

6     18

6     12

6     6

ALGORITM:

-citim a,b

-daca a*b scriem a+b

altfel cat timp a!=b executa

daca a>b atunci a=a-b  scade din a pe b

altfel scade din b pe  a b-b-a

afiseaza pe a

PSEUDOCOD:

-start

citeste a,b

-daca a*b=0 atunci scrie a+b

altfel  -cat timp a!=b executa

daca a>b atunci a=a-b

altfel b=b-a

scrie a

-stop

OBERVATII:

a.Numerele se modifica.Daca dorim sa  folosim numerele dupa calcului cmmdc atunci trebuie sa le  facem o copie (x=a;y=b).

b.Algoritmul este lent din punct de  vedere al timpului.

ALGORITMUL LUI EUCLID:

a        b           r

90     42       6

42         6      0

a         b         r

50      78    50

78      50     28

50       28     22

28        22     6

22          6      4

6            4       2

4           2         0

ALGORITM:

-citim a,b

-calculam r<-a%b

-cat timp r!=0 exexuta a<-b

b=r

r=a%b

PSEUDOCOD:

-start

citeste a,b

r=a%b

-cat timp r!=0 executa a<-b

b=r

r=a%b

-stop

OBSERVATII:

a.In urma calcului cmmdc numerele se modifica.Pentru a le folosi apoi trebuie sa  realizam o copie.

b.Algoritmul lui Euclid este mai rapid decat algoritmul prin scaderi repetate pentru ca folosim impartire.

Top filme 2010

Regizorii Hollywood au decis  ca  in anul 2010 sa  ne incante cu o prestatie fabuloase a filmelor.Sa vedem cele Topul celor mai bune filme 2010:

  • Inception
  • Shutter Island
  • How to Train Your Dragon
  • Harry Potter and the Deathly Hallows: Part 1
  • Prince of Persia: The Sands of Time
  • The Pacific
Titlu film Nota
1. Inception – Inceputul (2010) 9
2. Shutter Island (2010) 8.6
3. How to Train Your Dragon – Cum sa-ti dresezi dragonul (2010) 8.6
4. Harry Potter and the Deathly Hallows: Part 1 (2010) 8.5
5. Prince of Persia: The Sands of Time – Printul Persiei: Nisipurile Timpului (2010) 8.5
6. The Pacific (2010) 8.5
7. Alice in Wonderland – Alice în Tara Minunilor (2010) 8.5
8. Despicable Me – Sunt un mic ticalos (2010) 8.5
9. Red – Greu de pensionat (2010) 8.4
10. Charlie St. Cloud (2010) 8.3
11. The A-Team – Echipa de soc (2010) 8.3
12. Wall Street: Money Never Sleeps – Wall Street: Banii sunt facuti sa circule (2010) 8.3
13. Robin Hood (2010) 8.3
14. The Karate Kid (2010) 8.3
15. Grown Ups – Oameni mari si fara minte (2010) 8.2
16. Remember Me (2010) 8.2
17. Dear John (2010) 8.2
18. Shrek Forever After – Shrek pentru totdeauna (2010) 8.2
19. Repo Men (2010) 8.2
20. Letters to Juliet (2010) 8.2
21. Iron Man 2 (2010) 8.1
22. Extraordinary Measures (2010) 8.1
23. Step Up 3D – Dansul dragostei 3D (2010) 8.1
24. From Paris with Love (2010) 8.1
25. The Book of Eli (2010) 8.1
26. Unthinkable (2010) 8.1
27. StarStruck (2010) 8.1
28. The Chronicles of Narnia: The Voyage of the Dawn Treader (2010) 8.1
29. The Ghost Writer (2010) 8.1
30. The Sorcerer’s Apprentice (2010) 8.1
31. Leap Year (2010) 8
32. Green Zone (2010) 8
33. Salt (2010) 8
34. The Last Song (2010) 8
35. Knight and Day (2010) 7.9
36. Toy Story 3 (2010) 7.9
37. Clash of the Titans (2010) 7.9
38. Centurion (2010) 7.9
39. The Twilight Saga: Eclipse (2010) 7.9
40. The Expendables – Eroi de sacrificiu (2010) 7.9
41. Nanny McPhee Returns (2010) 7.9
42. Cop Out (2010) 7.8
43. The Runaways (2010) 7.8
44. The Wolfman (2010) 7.8
45. Marmaduke (2010) 7.8
46. The Losers (2010) 7.8
47. Kick-Ass (2010) 7.8
48. A Nightmare on Elm Street (2010) 7.8
49. Valentine’s Day (2010) 7.8
50. Camp Rock 2: The Final Jam (2010) 7.8
51. Percy Jackson & the Olympians: The Lightning Thief – Percy Jackson si olimpienii: Hotul fulgerului (2010) 7.8
52. The Spy Next Door (2010) 7.8
53. The Bounty Hunter (2010) 7.7
54. Cats & Dogs: The Revenge of Kitty Galore (2010) 7.7
55. Frozen (2010) 7.7
56. The Switch (2010) 7.7
57. Just Wright (2010) 7.7
58. Sex and the City 2 (2010) 7.7
59. My Name Is Khan (2010) 7.7
60. The Last Airbender (2010) 7.6
61. Resident Evil: Afterlife – Resident Evil : Viaţa de apoi (2010) 7.6
62. Date Night (2010) 7.6
63. Edge of Darkness (2010) 7.6
64. She’s Out of My League – Nu-i de nasul meu (2010) 7.6
65. Tangled (2010) 7.5
66. The Back-up Plan – Plan de rezerva (2010) 7.5
67. Undisputed III: Redemption (2010) 7.5
68. When in Rome (2010) 7.5
69. Predators (2010) 7.5
70. Tooth Fairy (2010) 7.4
71. Machete – Macete (2010) 7.4
72. High School Musical 4: East Meets West (2010) 7.4
73. Jurassic Park IV (2010) 7.4
74. Jonah Hex (2010) 7.4
75. The Crazies (2010) 7.4
76. Hot Tub Time Machine (2010) 7.3
77. TRON: Legacy (2010) 7.3
78. The Other Guys – Agentii de rezerva (2010) 7.3
79. Furry Vengeance (2010) 7.3
80. Takers – Fura si fugi (2010) 7.3
81. Killers (2010) 7.2
82. Crazy on the Outside (2010) 7.2
83. Legion (2010) 7.1
84. High School (2010) 7.1
85. Our Family Wedding (2010) 7
86. Quantum Apocalypse – Quantum Apocalypse – Ziua Judecatii (2010) 7
87. The Final (2010) 7
88. Duel of Legends (2010) 6.9
89. The Penthouse (2010) 6.8
90. Eu cand vreau sa fluier, fluier (2010) 6.8
91. The Graves (2010) 6.8
92. Halo Legends (2010) 6.7
93. S.N.U.B! (2010) 6.7
94. Woodshop (2010) 6.7
95. Get Him to the Greek (2010) 6.7
96. Wrong Side of Town (2010) 6.7
97. Death at a Funeral (2010) 6.7
98. Extremely Used Cars: There Is No Hope (2010) 6.6
99. Piranha (2010) 6.6
100. Smokin’ Aces 2: Assassins’ Ball (2010) 6.6